1

When I enter a search query, Magento returns "no results". I am not using any search-related extensions. Already tried reindexing.

Where should I start debugging this?

I am running Magento 2.2.8

  • By what keyword you are trying to search? – Ravi Soni Jul 1 at 9:07
  • regular strings, for example "shirt" – klaaskox Jul 1 at 9:18
  • This issue comes till the time of set up OR just after a few customizations? – Ravi Soni Jul 1 at 9:24
  • I am not completely sure. It did work fine, I think it stopped working after upgrading to 2.2.8 – klaaskox Jul 1 at 9:50
2

Solved this problem, apparently there was a problem with the indexer, which failed on duplicated entries on catalog_product_index_eav_temp:

SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry '3196-193-1-170-3196' for key 'PRIMARY', query was: INSERT  INTO `catalog_product_index_eav_temp` (`entity_id`,`attribute_id`,`store_id`,`value`,`source_id`) VALUES (?, ?, ?, ?, ?), (?, ?, ?, ?, ?)

To fix it I had to manually update +- 100 records in the catalog_product_entity_varchar table. For example: update value=170,170 to value=170

1

Please check in admin product attributes set as searchable.

eg:

  1. Store >> Attributes >> Product
  2. Search for Name
  3. Check Storefront Properties >> Use in Search set as YES
  • checked this, attributes were already set op searchable – klaaskox Jul 1 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.