0

i tried get symbol but it just show €

$currency_symbol = Mage::app()->getLocale()->currency(Mage::app()->getStore()->getCurrentCurrencyCode())->getSymbol();
0

This is the way of Magento 1.9 to get currency symbol, you are doing it correctly:

Mage::app()->getLocale()->currency(Mage::app()->getStore()->getCurrentCurrencyCode())->getSymbol();

If you are getting unusual currency symbol then check the symbol on backend:

  1. Open Magento admin panel, go to System – Manage Currency -> Symbols.
  2. Uncheck "Standard".
  3. Add a new symbol which you need enter image description here
  4. Click "Save Currency Symbol" in the right corner.
  5. Clear cache and check on frontend

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.