0

Issue

We have a custom attribute of "manufacturer". We've been using it for 9 months assigning it products and it appearing correctly in the shop sidebar / facet filters.

Today we noticed the filter count and product count did not add up.

To remedy we found the product that missing the "manufacturer" attribute, saved and went to preview the results.

Instead of the count now being correct, the attribute filter of "Manufacturer" was now missing. To test we removed the attribute from the product and the attribute filter of "Manufacturer" appeared again.

Attempts to resolve

  • We've dropped the product and recreated it.
  • Tried adding other manufacturers to the product - this worked!? But the manufacturer we're trying to add to the product causes this the filter to not display
  • Checked logs

What could be causing one attribute option to not work when all others do for just one product and not the rest?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.