Did anyone run into this problem before?

I get the following error when accessing Magento 2 site:

There has been an error processing your request

Below is the error log content. I ran permissions, compiled, re-index... and clear cache, but nothing changed

Magento\Framework\App\Http\Interceptor does not exist {"exception":"[object] (ReflectionException(code: -1): Class Magento\Framework\App\Http\Interceptor does not exist at /home/accountfolder/public_html/vendor/magento/framework/Code/Reader/ClassReader.php:19)"} []

  • Can you detail some of the things you have tried? Commented Jun 27, 2019 at 22:22
  • @DominicXigen I ran permissions, compiled, re-index, deploy... and flush cache
    – P. Paul
    Commented Jun 27, 2019 at 23:21
  • are you getting this error in local or on the server ? Commented Jun 28, 2019 at 2:02
  • @DominicXigen on the server
    – P. Paul
    Commented Jun 28, 2019 at 2:54

2 Answers 2


Since the dependency and interception files are not generated in the generated directory you are getting this error. Remove the static and generated files, deploy and compile to get the site up again

Please remove the following directories

rm -rf var/view_preprocessed  var/cache var/page_cache generated

Once done give the proper permissions using the below commands

find var pub/static pub/media app/etc generated/ -type f -exec chmod g+w {} \;
find var pub/static pub/media app/etc generated/ -type d -exec chmod g+ws {} \;
chown -R <Magento user>:<web server group> .

Finally, compile and deploy for the interception classes to be generated

php bin/magento setup:static-content:deploy

php bin/magento setup:di:compile
  • Thanks for the support. However, after doing the above, the site is still not up. When I tried accessing the site after doing the above I got the following error message: "An error has happened during application run. See exception log for details." And exception error log file shows the same error report.
    – P. Paul
    Commented Jun 28, 2019 at 16:16
  • Running "bin/magento setup:upgrade" then flushing cache solved the problem. Thanks!
    – P. Paul
    Commented Jun 29, 2019 at 9:19

This is common issue in Magento 2 while developer changing in classes or deleted the generated folder.

Magento did not founded the magento care class "Magento\Framework\App\Http\Interceptor". That's why this issue often comes.


Resolve it by simple step, run below command which check the dependency and regenerate or generate generated folder.

php bin/magento setup:di:compile php bin/magento cache:flush

then try again to execute your website it will run without any issue.

If you also face regard the css or theme issue then you have to run below command as well.

php bin/magento setup:static-content:deploy After that give permission to files and folder

chmod 777 generated var pub/static;

After that your website will run successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.