All custom modules have disappeared after upgrade to 2.2.9 from 2.1.9. When I run bin/magento setup:upgrade, last message is "Nothing to import." but the custom modules are not enabled and not added to the app/etc/config.php file.

  • Have you checked in setup_module table that there module's entry already exist or not? – Raj Jun 27 '19 at 6:56
  • Yes the custom modules already exist, do I have to remove them? – Mathieu Jun 27 '19 at 6:59
  • Yes you have to remove that entry and try to run setup:upgrade command – Raj Jun 27 '19 at 7:00
  • I removed a module and run setup:upgrade command, this module was not added to the config.php file and the setup_module table. – Mathieu Jun 27 '19 at 7:06
  • Strange. Have u checked any file missing for module like registration.php or modules.xml? – Raj Jun 27 '19 at 7:12

Issue solved, the app/etc/NonComposerComponentRegistration.php file was absent.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.