0

Magento 2.3.1 is failing to connect to Shipworks via REST API. The error it is giving is

The remote server returned an error: (401) Unauthorized.

When traced with Fiddler the result is

{"message":"The consumer isn't authorized to access %resources.","parameters":{"resources":"Magento_Sales::actions_view"},"trace":"#0 /home/buyglasswoodstov/public_html/vendor/magento/module-webapi/Controller/Rest/RequestValidator.php(68):

I attempted reading through Magento Docs but I am very unfamiliar with REST API. Any help would be appreciated. Thanks!

0

I just migrated to 2.3.1 this week and Shipworks worked on the 1st try. I followed the steps on their support page. Since I'm keeping magento 1 around until those orders are closed out, I had to buy a 2nd license and then migrate the 1st license via phone call to the new URL.

Maybe this could be the culprit: I observed that the backend only allows one login instance per username. I already knew this before trying to connect, so I created the new user. You also need to go to the System => All Users -> User Role tab and explicitly make the new user Admin.

|improve this answer|||||
  • I worked through the support page as well as contacted shipworks customer support and concluded it is something not working in my magento setup, but I have no idea what. In shipworks when setting up the store, my account connects fine, but I get this error message when I go to download new orders – Josiah Jun 25 '19 at 14:49
  • Did you set up a different user just for shipworks and also make sure they are in the administrators user role? It sounds like that error is about user permissions. ShipWorks will use the REST and log in like in your Admin panel. If you are already logged in and your credentials are in ShipWorks, I could see how that would error. – Chris K Jun 25 '19 at 14:55
  • I see what you mean, but yes I have created a new admin account specifically for shipworks and I still get the 401 error. Additionally I cleared all cache, completely shutdown shipworks and restarted my computer to ensure it was loading a fresh profile. – Josiah Jun 25 '19 at 15:01
  • They are pretty helpful when you call them... please let us know the outcome for the next visitor. – Chris K Jun 25 '19 at 21:13
  • 1
    I just created a fresh install of vanilla Magento 2 on the same server and still received the same error.... – Josiah Jul 10 '19 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.