0

Fairly new to Magento 2. I recently built one site using a Luma child theme and all went (fairly) well, now on my second site - different host - which is basically a copy of the first one, same exact template, just a few cosmetic changes to CSS and block positioning, so I wouldn't expect a very different behaviour.

However, on this site I seem to be having some cache related problems. For example if I leave the site for a day or two, when I go back to it (no one has touched it in the meantime) the product images on the homepage won't load up. On one occasion, the whole homepage content (between the header and footer) suddenly wasn't loading up.

In all cases, clearing the cache in the backend fixes the problem, but I know this shouldn't be happening. There isn't even any notification in the backend that the cache needs clearing. I can't go live with the site until this problem is fixed, but I'm not sure how to diagnose where the cache is compromised.

Given that basically the same site behaves properly on another host, I have to assume that it's to do with server settings. Any suggestions?

  • can you check it's mode, you can use this command in ssh: php bin/magento deploy:mode:show – Jimit Bhavsar Jun 24 at 13:41
  • Current application mode: default. And - the problem is back today, no content on the homepage. No errors showing in the Chrome console either. Deliberately not refreshing the cache for now. Page is expresschems.co.uk – webrightnow Jun 25 at 17:44
  • Maybe also worth mentioning, adding /index.php to the base URL brings up the custom CMS blocks, but the product thumbnails are not rendering. Upon inspection of the source code, Magento seems to be looking for https versions of the thumbnails, which causes ERR_CERT_AUTHORITY_INVALID errors, as the site is currently non-SSL. I have not enabled SSL anywhere in the backend. This only happens on the homepage. The same thumbnails on category pages are calling http sources and loading up fine. – webrightnow Jun 25 at 18:23
  • I tell a lie, I checked the "Secure Base URL" field in the admin and it does show the https URL, even though I'm sure I never filled that myself, so it must be there by default. However, "Use Secure URLs on Storefront" is set to "No". – webrightnow Jun 25 at 18:38
  • 1
    Thanks Jimit, I've enabled production mode and right now all the content is showing. I will report back if there's any further issues. – webrightnow Jun 27 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.