1

Product SKU based AND PRODUCT NAME SEARCH Not working properly if SKU consists of a special character like (space, dot, etc) it results not giving the exact result.

Is there any solution for this? Please give your valid comments, please...

0

For getting exact result you have to enable Elastic Search, make sure only in attribute SKU and Product search is enabled, check other attributes i.e. description, etc , Search should be disabled there.

  • Thanks for your reply, we enabled attribute level prnt.sc/o5us2s and Elastic Search in catalog section as per the screen shot prnt.sc/o5ut08 can please check is any thing missed or not in screen shot. – QA magento 2 Jun 24 at 7:53
  • Please check this screenshot for description attribute: https://prnt.sc/o68quw and make Use in Search yes for Name and SKu only. For better result, enable Elastic Search... – temper Jun 25 at 4:36
  • Thanks for your reply, We set 'Use in Search' property as "YES" to Name and SKU attributes Only , but it not gives actual result. our sku like "10SOVL-3x5.1", "10SOVL-2x3a" etc... Elastic Search 5.1 enabled and its test connection gives success message... – QA magento 2 Jun 25 at 6:00
  • I faced the same issue, and am using elastic search and it is giving me exact result now, please clear cache and check again. It should be work. – temper Jun 25 at 6:06
  • Please check this screenshot aswell,, prnt.sc/o69i6n – temper Jun 25 at 6:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.