0

Have just had a developer implement Varnish cache with SSL termination.

http:s// --> nginx(443) --> varnish(port 8081) --> apache(8080)

All pages on our site are working fine except the home page which is returning Server 500 error.

I believe its an Nginx.conf error. Can anyone spot what might be going wrong?

I am just guessing its something to do with the below line

return 301 https://www.ourdomain.co.uk$request_uri;

Full config below. Any help appreciated

# For more information on configuration, see:
#   * Official English Documentation: http://nginx.org/en/docs/
#   * Official Russian Documentation: http://nginx.org/ru/docs/

user nginx;
worker_processes auto;
error_log /var/log/nginx/error.log;
pid /run/nginx.pid;

# Load dynamic modules. See /usr/share/nginx/README.dynamic.
include /usr/share/nginx/modules/*.conf;

events {
    worker_connections 1024;
}

http {
    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  /var/log/nginx/access.log  main;

    sendfile            on;
    tcp_nopush          on;
    tcp_nodelay         on;
    keepalive_timeout   65;
    types_hash_max_size 2048;

    include             /etc/nginx/mime.types;
    default_type        application/octet-stream;

    # Load modular configuration files from the /etc/nginx/conf.d directory.
    # See http://nginx.org/en/docs/ngx_core_module.html#include
    # for more information.
    include /etc/nginx/conf.d/*.conf;

    server {
        listen       80;
        server_name  www.ourdomain.co.uk;
    #    include /etc/nginx/default.d/*.conf;
    #location / {
    #    proxy_pass http://ourIPaddress:8081;
    #    proxy_set_header Host $http_host;
    #    proxy_set_header X-Forwarded-Host $http_host;
    #    proxy_set_header X-Real-IP $remote_addr;
    #    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    #    #proxy_set_header X-Forwarded-Proto https;
    #    #proxy_set_header X-Forwarded-Port 443;
    #}
    return 301 https://www.ourdomain.co.uk$request_uri;
    }



    server {
        listen       443 ssl http2;
        server_name  www.ourdomain.co.uk;
        ssl_certificate "/etc/letsencrypt/live/www.ourdomain.co.uk/fullchain.pem";
        ssl_certificate_key "/etc/letsencrypt/live/www.ourdomain.co.uk/privkey.pem";
    ssl_trusted_certificate "/etc/letsencrypt/live/www.ourdomain.co.uk/chain.pem";
        ssl_session_cache shared:SSL:1m;
        ssl_session_timeout  10m;
        ssl_ciphers HIGH:!aNULL:!MD5;
        ssl_prefer_server_ciphers on;
        include /etc/nginx/default.d/*.conf;
    location / {
        proxy_pass http://ourIPaddress:8081;
        proxy_set_header Host $http_host;
        proxy_set_header X-Forwarded-Host $http_host;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        #proxy_set_header X-Forwarded-Proto https;
        #proxy_set_header X-Forwarded-Port 443;
    }
    }

}
0

error code 500 = you have something wrong with magento settings, incorrect extension configuration, or php error.

if you have only home page error then disable any custom widgets or blocks. load default page.

if you lucky you can probably see something in logs. but usually error code 500 breaks without any further actions.

you can use php debugger or Strace. you can down the issue to a particular system call.

  • Home page works fine when using built in cache. Can't see any console errors or any issues in the logs. Thanks for the info will keep digging – Nadroj467 Jun 21 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.