0

I have configured Authorize.Net Payment method in Magento 2.1.7, In checkout page, I'm using credit card transaction both production and test mode while placing the order, I am getting "An error occurred on the server. Please try to place the order again".

Activating debug mode I didn't get any log files. Please Let me know it is a Magento issue or payment gateway issue.

  • can you please check if in magento log settings are enabled or not. ? – nishu Jun 21 at 9:55
  • please check consol or magento log file and try to resolve that error. – Dhiren Vasoya Jun 21 at 10:10
  • in log file only showing cache invalidate issue. it's not related to payment gateway issues. – Lucky Jun 21 at 10:22
  • Please make sure able to place an order without authorize.net – Arunprabakaran M Jun 21 at 11:06
  • Cash on delivery and Paypal gateway working properly. In authorize.net order will be placed in the backend without transaction id and status is pending. – Lucky Jun 21 at 11:08
0

For Sandbox mode,please check your configuration as following settings are working fine for me @Magento2.2.4:-

enter image description here

enter image description here

enter image description here

enter image description here

Hope this will help you.

  • Thanks for the answer above settings are fine in my Magento. We discuss with Authorize.net support team They said Magento didn't send the transaction payment request to Authorize.net gateway. – Lucky Jun 24 at 5:46
0

Thanks for the support guys, finally found the issue. The patch update file Request.php in authorize.net is not working properly.
Line no.209

private function getSignatureKey(): string
  {
    return $this->signatureKey;
  }

and Response.php Line No. 109

 foreach ($hashFields as $field) {
            $message .= ($this->getData($field) ?? '') . '^';
        }

The above types of representations is not working in Magento 2.1.7 with PHP 5.6.
We tested in new Magento instance with PHP 7.0.2 Authorize.net working properly without any transaction error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.