0

A customer's 'internet service company blah blah blah' did 'something' we do not know on a previously working 1.9.2.1 installation.

Fontend works.

But when accessing /admin we got no error but a redirect to /index.php/admin/index/index/key/<some_random__key>/

And, so, we cannot access no more to admin panel.

Also, I tried to navigate to

  http://www.customerdomain.ext/downloader

It works, and, here, the login works.

I tried to select one of the lib and choose 'reinstall', but I got an iframe with the downloader login form....

I've no previous experience with Magento.

Please note: Our customer is on a shared host. We can read apache error logs but there are NO error logged. And I cannot login with bash and upgrade it.

I'm asking some idea of possible source of this error.

Yes, we know, this MUST BE UPDATED. But, first, we must make it works again.

  • Try logging into the admin using browser private mode / incognito – Dominic Xigen Jun 17 at 17:18
0

First make sure you have really cleared all cache and cookies on your browsers. Just in case.

Then after a log in attempt try the path index.php/admin/sales_order/index/key/{the same key it just gave you}/ just to check if you are perhaps logged in and just not being taken there.

It's not a "cookie cutter" answer question but here are some things you can look at that a shared hosting setup could mess up

It would be best if you can find out what exactly they might have done, it would help a lot!

  • they could update the php version
  • they could ovewrite the .htaccess file of Magento, which controls routing and could affect access to admin
  • they could wipe a symbolic link that is needed (though that wouldnt just break admin)
  • they could change the "internal main domain" of your virtual host, which could lead to domain cookie issues which can affect login

If you have cpanel or ftp access, you should have a look at var/logs within your magento installation and see what is there. If nobody's ever bothered the files could be humongous. If that is the case I recommend you rename them then try to log in again and some new tinier files should have appeared. There could be some hints there (but for example many of the problems above would not result in log entries)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.