1

I have encountered an order view error. When I view an order in the magento2.2.6 background, it displays

"Information Changes have been made to this section that have not been saved. This tab contains invalid data. Please resolve this before saving."

Instead of order details. I found some of the same problems on Google. I disabled Temando_Shipping modules according to their solution, but it didn't solve my problem, I still can't view this order. And I don't see the error log related to this problem. Can someone help me?

  • For debugging purposes first disable all custom modules one by one, and after disabling each custom module, run php bin/magento setup:upgrade command. – Mohit Kumar Arora Jun 14 at 8:09
  • @MohitKumarArora I found the cause of this error, I think it is not a module problem. All the orders that can not be opened have the same product, I deleted the product yesterday, I don't know why deleting the product will cause this error, how should it be solved? And I ran this command php bin/magento setup:upgrade – yoyo Jun 14 at 8:18
0

Run this :

  • php bin/magento module:disable Temando_Shipping --clear-static-content
  • rm -rf generated/* var/view_preprocessed/* var/view_preprocessed/* pub/static/*
  • php bin/magento setup:upgrade && php bin/magento setup:di:compile && php bin/magento setup:static-content:deploy -f
  • @YIgen Guxholli I ran these commands, but it didn't work. I found the cause of this error, I think it is not a module problem. All the orders that can not be opened have the same product, I deleted the product yesterday, I don't know why deleting the product will cause this error, how should it be solved? – yoyo Jun 14 at 8:38
  • @yoyo Check if the product is disabled , or has an error while accessing it , but mostly check if it is disabled/outofstock – Ylgen Guxholli Jun 14 at 8:44
  • @YIgen Guxholli I deleted a few products, not disabled. I can't view the order when the previous order contains the product I deleted. I don't know what I should do to see the order. – yoyo Jun 14 at 8:48
  • @yoyo than go and do a full reindex php bin/magento indexer:reindex , try again and let me know – Ylgen Guxholli Jun 14 at 8:54
  • @YIgen Guxholli prnt.sc/o1qn7v, Still useless – yoyo Jun 14 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.