1

I have upgraded the Magento version from 2.2.6 to 2.3.0 via composer. I have tried running the command php bin/magento setup:upgrade but it says the below error

There are no commands defined in the "setup" namespace

What could be the issue?

Please, anyone, help me

5
  • I have two question 1) Are you using windows or linux? 2) Are working in local with xampp? Jun 13, 2019 at 5:51
  • @Sanjay Gohil, Windows
    – Siva
    Jun 13, 2019 at 5:52
  • @Siva, I am face same issue earlier, I have solved by setting php environment variable. First of all check your xampp php version whether it is compatible with Magento 2.3.0, and then set php environment variable. Jun 13, 2019 at 5:58
  • I have checked and see that PHP version which we have is compatible with Magento 2.3.0
    – Siva
    Jun 13, 2019 at 6:21

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.