0

I have developed an extension for Magento Marketplace.

For this, I had installed code sniffer Magento coding standard.

But Marketplace checks All the Standards and Compatibility of Extension with Multiple Magento version like 2.0., 2.1., 2.2. and PHP versions also like 5.6., 7.0., 7.1., 7.2.*, etc.

So I want to configure my computer for checking my extension compatibility and First, I want to test in the local environment and after that submit to Marketplace.

For this what I need to do?

1

Docker is the best solution for this kind of issue according to me.

if you are working multiple versions of the same system so create multiple Docker images of Magento Hope this helps thanks.

1

You can use a codesniff ruleset to scan your code

https://github.com/PHPCompatibility/PHPCompatibility

Use it a bit like this

https://magento.stackexchange.com/a/277385/70343

update

In response to your comment I dev on something based on this.

https://github.com/meanbee/docker-magento2

As the other answer suggests docker is good for this. You can switch php version with a docker compose config change.

  • I have already set coding standard in my machine I am only want to set multiple php version for magento so if you have any solution about this then provide me thank u 😀 – Bhavesh Prajapati Jun 7 at 11:58
  • Updated my answer – Dominic Xigen Jun 7 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.