0

I have enabled system logs in magento 2.3.1 using command bin/magento setup:config:set --enable-debug-logging=true But, after enabling it, I am unable to run any command in terminal and getting message - Magento supports PHP 7.1.3 or later. Please read https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html..

I want to disable the system logs, no command is working in terminal. Please provide a solution to disable it either through admin or database.

Thanks

0

Check in your app/etc/env.php file, there should be something like:

    'dev' => [
        'debug' => [
            'debug_logging' => 1
        ]
    ]

Try removing it and check again if you can run commands

  • I have removed it but still unable to run any command. – chanchal Jun 6 '19 at 6:35
  • And what is your php version? Have you checked the cli version too? – SantiBM Jun 6 '19 at 6:38
  • The default php version on server is 7.0 and the site I am working on is setup on Php 7.1 and it's cli version in also 7.1. But after enabling debug log it is showing issue of default PHP version on cli and not able to run any command. – chanchal Jun 6 '19 at 6:41
  • I'm trying in a php 7.2 server without any issues, can you easily change the php to 7.2 to test? – SantiBM Jun 6 '19 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.