0

Using Magento 2.3.1

Added a product with weight 220LB to the cart ( the cart weight > 200lb ), proceed to checkout, but the Shipping methods are not showing up. There is no restriction for shipping methods. Shipping methods FLAT RATE, STORE PICKUP, UPS, CANADA POST are configured.

UPS & CANADA POST CARRIES have weight restriction but, FLAT RATE, STORE PICKUP has no restriction, though these methods are not displaying.

Please help to find the solution.

  • Is it a simple product? Have you tried setting the weight as 1lb? – Dominic Xigen Jun 5 '19 at 20:57
  • It's a Simple Product. I have tried setting the weight 1LB, displays shipping methods. Thank you. – Bhavana Thodeti Jun 5 '19 at 21:03
  • So you agree it's weight related? – Dominic Xigen Jun 5 '19 at 21:34
  • Yes, if I change the weight of the cart to lower, shipping methods are displaying. – Bhavana Thodeti Jun 5 '19 at 21:36
  • Are any of your shipping extensions you use custom? Or are you using the default extensions? – Dominic Xigen Jun 5 '19 at 21:42
0

As discussed in comments it is a weight issue.

I believe either the store pickup or Canada post extension is causing this issue.

As the issue is easy to recreate I would reach out to the develops of the extensions. Show them the problem you are experiencing and see if they can determine whether or not their extension is the cause.

| improve this answer | |
  • Yes, Problem with the Canada post extension. Thank you. – Bhavana Thodeti Jun 5 '19 at 23:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.