0

I have installed Magento 2.3 and then installed custom paid theme.After this when i open my contact page the page shows 404 error. i have check the controller URL and other things to debug but i don't found any solution.

so my question is , do i need to create a CMS page for contact? I have enabled the page from Back-end but still 404 Error. I disabled all the module and changed the theme to Luma but still 404 error.

http://prntscr.com/nw35ty

Any one tell me how i can debug this?

2
  • Is the order page like Customer login,registaion page is opening?
    – Amit Bera
    Jun 1, 2019 at 3:53
  • Yes all the other pages are opening.
    – sudo55
    Jun 1, 2019 at 5:36

1 Answer 1

0

You do not need to create a CMS page for the contact us page.

If you do and it shares the same url key that could be what's causing problem. In which case delete any CMS page with 'contact' url key.

Have you tried different URL options

https://domain.com/contact/

https://domain.com/contact

https://domain.com/index.php/contact/

https://domain.com/index.php/contact

Maybe try http:// too for all of the above. Just rule out some weird routing issue.

5
  • Yes. By using this www.abc.com/index.php/contact is working. How i can set this to normal url?
    – sudo55
    Jun 1, 2019 at 0:10
  • So that means controller and layout XML is good. Check url rewrites is on docs.magento.com/m2/ce/user_guide/marketing/… , alsp check rewrites themselves docs.magento.com/m2/ce/user_guide/marketing/… you are looking for anything that has contact as request path and doesn't look right Jun 1, 2019 at 7:08
  • followed the above links but none of the are useful for me.
    – sudo55
    Jun 1, 2019 at 14:29
  • In admin, Marketing > SEO & Search > URL Rewrites. Look for any request path that says /contact/ or similar. Jun 1, 2019 at 18:30
  • there is no path having Contact or similar
    – sudo55
    Jun 1, 2019 at 23:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.