0

I have tried all commands on our Magento 2.3.0 website but I am getting issue after changing to production mode. So if anyone is facing this type of error, please reply to me the proper solution. Admin side is not clickable and getting below error on the console

TypeError: require is not a function
921eba372ebcf7d66b86f7adae7cab0606c79d7f0594d4b36501050683d2a99b:95:1
    <anonymous> https://XXXXX.co.uk/oasis18/admin/dashboard/index/key/921eba372ebcf7d66b86f7adae7cab0606c79d7f0594d4b36501050683d2a99b/:95

TypeError: require.config is not a function requirejs-config.js:57:9
6
  • Run: cache flush, di compile and static content deploy. – Sukumar Gorai May 31 '19 at 13:32
  • already i apply it but actually in our other server my staging site working it when i change it production mode but when i apply production on live site there issue getting – Rv Singh May 31 '19 at 13:34
  • Check console if css and js files are loading correctly or not. Also try to delete generated/code, generated/metadata, pub/static/adminhtml, pub/static/frontend, pub/static/_cache, pub/static/requirejs(if there), var/view_preprocessed, var/cache and var/page_cache. Then run di:compile and static content:deploy. – Sukumar Gorai May 31 '19 at 13:44
  • already i try this here console this error getting in admin side and frontend side same error getting – Rv Singh May 31 '19 at 13:45
  • i am stuff this issue because in staging my site work properly after production mode but in client server there getting issue i am not clickable in magneto admin side only dashboard showing. – Rv Singh May 31 '19 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.