0

When I call the third party HTTP URL in my page. Then, I face the below error.

How can I solve it?

Mixed Content: The page at 'https://*******************' was loaded over HTTPS, but requested an insecure resource 'http://***************************'. This request has been blocked; the content must be served over HTTPS.

  • Refer the link you can help. magento.stackexchange.com/questions/195440/… – Kirti Nariya May 29 '19 at 4:47
  • I have already done this process. but It's not working yet. – Dharmik Ponda May 29 '19 at 4:53
  • refer this url to https - developers.google.com/web/fundamentals/security/… – Anas Mansuri May 29 '19 at 4:56
  • I have try using add "<meta http-equiv="Content-Security-Policy" content="upgrade-insecure-requests">" in head but It's not worked. And for the other one "copy the content of URL", I can't accept this way because I have a large amount of data. @AnasMansuri. – Dharmik Ponda May 29 '19 at 5:03
  • 2
    Or maybe let me revise my question. Why you need to make it http only? If it is on your control then just change to https. If not then I have another simple solution for you. Just create a page on your server which can be served over https and from that page do another curl request to get the http content. Might not be possible always but just throwing options for you to have more ideas – Arif Ahmad May 29 '19 at 6:00
0

You can refer below link for same block HTTP Request an HTTPS page.

Mixed Content: This request has been blocked; the content must be served over HTTPS

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.