2

There are several errors when I'm trying to install an extension (Slider Banner Module) for the first time. The picture below shows the error in the readiness check. I'm using GoDaddy > C-Panel > Magento 2.3.1 on Windows 10 with PHP version 7.2

Readiness Check Failure 1) For the Check Cron Scripts errors, I am able to solve it by manually change

$setupCheck = $this->cronScriptReadinessCheck->checkSetup();

$updaterCheck = $this->cronScriptReadinessCheck->checkUpdater();

to

$setupCheck = ['success' => 1];

$updaterCheck = ['success' => 1];

I'm not sure if that is the correct way to fix it since there are no .setup_cronjob_status and .update_cronjob_status files in var.

2) For the Dependency error, I have tried to remove "require-dev": in composer.json file but the error still persist.

3) For the PHP Settings Check error, I tried to change the memory limit in .user.ini and .htaccess from memory_limit = 756M to memory_limit = 2G, however, the C-Panel > PHP Selector > Options > Memory_limit still stays at 756M. PHP Memory Limit

4) PHP Extensions Checks is as the picture below (Default Value) PHP Extensions

  • Do you have shell access? – Shoaib Munir Jun 4 at 5:05
  • Yes, I'm currently using Putty and able to access my hosting server through it. – Nicholas Chow Jun 4 at 5:08
  • check if you can setup cron on it. use crontab -e to check if cronjobs are set – Shoaib Munir Jun 4 at 5:09
  • The output for crontab -e is: ~ (empty) "/temp/crontab.XXXXX8NHQq" 0L, 0C 0,0-1 All. There were no output for crontab -l.I have set up cron in the Magento Admin > Stores > Configuration > System > Cron according to this link (mageplaza.com/kb/…). – Nicholas Chow Jun 4 at 5:38
  • 1
    Admin configuration is good, but you also need to set cronjobs on shell. Wait, let me add this one in anser – Shoaib Munir Jun 4 at 5:43
2
  1. Access shell of your hosting
  2. Go to your project directory
  3. Execute this command inside your magento directory:
    php bin/magento cron:install

  4. After installation of cron, set directory permissions by executing these commands
    chmod -R 776 var/ chmod -R 776 pub/ chmod -R 776 generated/ chmod -R 776 vendor/

  5. Check .htaccess of your magento directory and pub directory. See if it has php_value memory_limit value set, If it isn't then set it to php_value memory_limit 2G or if it is already there then make sure it is set to 1G (Take backup of your .htaccess first :) )

  6. Also check max_execution_time it should also set to 120 or more

  7. If above steps didn't work for you then, set file permission to 777 from your godaddy cpanel on the directories that I have listed

Check readiness test after this.

  • Thank you Shoaib, after executing those commands, the 1) Check Cron Scripts problem is resolved (There are .setup_cronjob_status and .update_cronjob_status files in var. 2) PHP Settings Check and PHP Extensions Check are also resolved. Only the Check Component Dependency problem still persist (We found conflicting component dependencies). – Nicholas Chow Jun 4 at 6:23
  • That's good :). Please check point 5, I have updated my answer, check if it works for you – Shoaib Munir Jun 4 at 10:14
  • I tried changed the values as per recommended by you, however, I still receive the dependency error. Both the php_value memory_limit values in root and pubare 756M. I'm only able to change it to 1G by modifying memory_limit in .user.ini (Confirm after checking php_info()). Output for php_info() is memory_limit = 1G, max_execution_time = 18000 (Local Value) , memory_limit = 756M, max_execution_time = 0 (Master Value). – Nicholas Chow Jun 4 at 14:00
  • Sorry Nicholas, as recommended in the issue raised on github, you need to set memory_limit to 2G. Please see the link for clarification github.com/magento/magento2/issues/20684#issuecomment-484020760 – Shoaib Munir Jun 4 at 20:09
  • I've changed the php_value memory_limit = 2G and max_execution_time = 120 but the We found conflicting component dependencies error is still there. According to php_info(), the local value has changed accordingly but the Master Values are memory_limit = 756M, max_execution_time = 0 (not sure if that's relevant). – Nicholas Chow Jun 5 at 1:11
1

I have faced same issue and fixed to set cron and permission

For your problem if you are setup cron correctly there must be two files generated in var directory called .setup_cronjob_status and .update_cronjob_status if this two files are generated you are ready to run websetup wizard. Also check the permission of both generated file is correct or not.

Refer bellow link for further information.

https://devdocs.magento.com/guides/v2.3/config-guide/cli/config-cli-subcommands-cron.html

https://devdocs.magento.com/guides/v2.3/comp-mgr/trouble/cman/component-depend.html

  • thank you for your reply. Can you guide me through the process of fixing this problem? Do I run php bin/magento cron:install [--force] command in Putty? – Nicholas Chow May 30 at 0:30
  • Have you set cron? – Kirti Nariya May 30 at 15:59
  • Kirti, I have set up cron in the Magento Admin > Stores > Configuration > System > Cron according to this link (mageplaza.com/kb/…). However, there's still no .setup_cronjob_status and .update_cronjob_status files in var. – Nicholas Chow Jun 3 at 2:03
  • Run cmd: crontab -e And check cron has set or not ? – Kirti Nariya Jun 3 at 4:49
  • The output for crontab -e is: "/temp/crontab.XXXXX8NHQq" 0L, 0C 0,0-1 All. The output for crontab -l is empty – Nicholas Chow Jun 3 at 5:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.