1

I'm running a Magento 2.X.X instance on a dedicated CentOS 7 server.

I'm trying to integrate the Linnworks API but it would seem it's a lot more complicated than I thought it would be.

In Linnworks

  1. I went into Settings > Channel Integration
  2. Clicked Add New and selected the Magneto 2 option
  3. Checked autofilled form - all good so hit Step 2
  4. Went into Magento Backend

In Magento

  1. I went into System > Extensions > Integrations
  2. I added my new Linnworks integration with following details:
    • Name: Linnworks
    • Callback URL: Copied from the Linnworks site
    • Identity Link URL: Copied from the Linnworks site
  3. Went into the API tab and manually ticked every box
  4. Hit Save and Activate

This is where the error comes up, it's just a plain-text webpage with this message:

Something went wrong: "oauth_consumer_key" is required. Enter and try again, "oauth_signature" is required. Enter and try again, "oauth_signature_method" is required. Enter and try again, "oauth_nonce" is required. Enter and try again, "oauth_timestamp" is required. Enter and try again

I've tested this with a vanilla Magento install, no plugins, no additional code and the error persisted.

I did actually test another API (ClickAndDrop) on my local machine and dev server, and that all worked, which made me think it's something server-level. However, I raised a ticket and they made amendments but to no avail.

I'm not really quite sure how to resolve this error or how to even debug.

I've also tried selecting (on Linnworks side) OAuth Manual and Admin login.

Admin login doesn't work, and Magento2 doesn't generate the Access tokens for whatever reason. I was able to get the Access Token like this:

curl -X POST "https://my.store.co.uk/index.php/V1/integration/admin/token" -H "Content-Type: application/json" -d '{"username":"someUser", "password":"somePass"}'

but couldn't get the access token secret, so can't test fully that method.

How do I resolve?

Edit:

It's not a third-party module. It's default Magento 2 API behaviour that's not working o.O - I'm just using Linnworks as an example

closed as off-topic by sv3n, saravanavelu, Manashvi Birla, Priyank, HelgeB May 23 at 14:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about third-party modules are generally off-topic because the scope of functionality and code are not available. For more information, see this meta post/answer." – sv3n, saravanavelu, Manashvi Birla, Priyank, HelgeB
If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.