1

Using MCE 2.3.1 and all products are downloadable. After a purchase, the customer is sent an Email verifying the purchase and it has a link back to their My Downloadable Products. When the link is pressed, it goes to their My Downloadable Products page with a list of the purchases and the error "The link is not Available". Also the individual download links next to each product are missing. It shows the items Pending, but the 2.3 User Guide, p223 indicates Pending or Invoiced state is good for delivery. I have checked the server location for files and permissions. Number of downloads is 3 and it shows 3 downloads are available.

Please help as my website is down, unable to deliver product. Thanks Bob

enter image description here

0

The status of your download is "Pending." Did you invoice the order yet? If you don't invoice the order, the link status will not be set to "Available." Perhaps your payment method is not set to auto-invoice? Did anything change recently?

Just so you have a reference, the logic for setting the status is here: \Magento\Downloadable\Observer\SetLinkStatusObserver::execute. You may want to look at your "order item" record and compare it with the logic in this method.

  • Perry, Thanks very much for your post. – Robert Sheahan May 24 at 14:32
  • I can see that the customer My Downloadable Products says "Pending" under Status but in the Magento Admin, Sales, Information, it shows the Order Status as "Closed". So if the download link after the title does not display while Pending, I need to figure out why the customer is not seeing "Available" as shown in Page 851 of 2.3 User guide. Any more suggestions? Please be specific as I do not know the workings or code of Magento, only what can be done through the Admin panel. Thanks. – Robert Sheahan May 29 at 17:30
  • I was able to delete the redundant status by using the Unassign link. I am still not sure how to set the three PayPal status as shown above. – Robert Sheahan Jun 5 at 13:36
  • 1
    I found out today that this is a Magento 2.3.1 bug in the code. More details can be found in Github Pull 22658 github.com/magento/magento2/pull/22658 and Github Issue #22354 github.com/magento/magento2/issues/22354 – Robert Sheahan Jun 5 at 18:52
  • This notice that the fix is complete was posted today: magento-engcom-team added this to the Release: 2.3.3 milestone 20 hours ago (7/7/19) No word yet on release of the new 2.3.3 release. – Robert Sheahan Jul 8 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.