0

I've got a problem with category pages: whenever a subcategory has any number of products inside, then the category page works. But, if the subcategory is empty, it just returns 404, not "no items in this category" or something like that, just 404, even if i select "show blocks and products", it doesn't find the page. Not even if I try to reach it via /catalog/category/view/id/xxx... I'm absolutely clueless as to why this happens. Has anyone got any idea? I've already looked for solutions on google and stack-overflow, but I didn't find anything related to my specific problem. Maybe I'm doing something wrong? I've also tried to indexer:reindex and setup:static-content:deploy, but to no effect...

  • Did you check URL exists in url_rewrite? – Ravi Soni May 21 at 11:18
  • Yes, it does, and it looks something like request: /category/category/category.html; target: /catalog/category/view/id/xxx – Riccardo Ronconi May 21 at 11:22
  • Please try manual URL like, localhost/magento227/<your category URL Key which is in "Search Engine Optimization">.html – Ravi Soni May 21 at 11:46
  • you mean like mydomain.com/category/subcategory.html (with category and subcategory being URL keys from SEO)? I've tried that – Riccardo Ronconi May 21 at 11:49
  • Then need to check more, Please check log – Ravi Soni May 21 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.