1

I installed elasticsearch into my server using the following guide: https://devdocs.magento.com/guides/v2.3/config-guide/elasticsearch/es-overview.html

So I have elasticsearch 6.7 installed right now but inside my Magento 2.3.1 (CE) backend I can only see this:

Search Engine

  • MYSQL
  • Elasticsearch
  • Elasticsearch 5.0+

I also updated my composer.json file with:

"elasticsearch/elasticsearch": "~2.0|~5.1|~6.7"

I want to fix this problem because when I run the reindex this happens:

{"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"Enabling [_all] is disabled in 6.0. As a replacement, you can use [copy_to] on mapping fields to create your own catch all field."}],"type":"illegal_argument_exception","reason":"Enabling [_all] is disabled in 6.0. As a replacement, you can use [copy_to] on mapping fields to create your own catch all field."},"status":400}

And I think the source is probably this difference between the versions.

1

https://devdocs.magento.com/guides/v2.3/mrg/ce/Elasticsearch6.html

you probably have this module disabled somehow:

Magento_Elasticsearch6

Magento 2.3.1 default search modules:

Magento_Search
Magento_CatalogSearch
Magento_AdvancedSearch
Magento_Elasticsearch
Magento_InventoryCatalogSearch
Magento_InventoryElasticsearch
Magento_Elasticsearch6

please check your modules:

bin/magento module:status
bin/magento module:enable Magento_Elasticsearch6
bin/magento cache:clean

=========================================

debug

if you check your modules folder:

ls -l vendor/magento/module-elasticsearch-6/

and its empty, depends on your circumstances, you can try to install this module:

su magenx -s /bin/bash -c "composer require magento/module-elasticsearch-6"
Using version ^100.3 for magento/module-elasticsearch-6               
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 1 install, 0 updates, 0 removals
  - Installing magento/module-elasticsearch-6 (100.3.0): Loading from cache
Writing lock file
Generating autoload files
| improve this answer | |
  • Thanks for the response, I tried to check if the module Magento_Elasticsearch6 was installed and/or enabled but with a quick bin/magento module:status I can't really find it. Shouldn't my composer require (from my post) install it or am I missing something? – Meow Meow I'm a Cow May 20 '19 at 7:39
  • 1
    check updated answer. probably you dont have this module in codebase. – MagenX May 20 '19 at 11:16
  • Thank you very much, your updated answer solve my problem! Accepted – Meow Meow I'm a Cow May 20 '19 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.