0

I want to execute cron every day at 10.05 so i have define crontab.xml as below

<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:module:Magento_Cron:etc/crontab.xsd">
    <group id="default">
       <job name="test_cron" instance="Vendor\Module\Cron\Test" method="execute">
            <schedule>5 10 * * *</schedule>
        </job>
    </group>
</config>

and this "test_cron" not iserted in "cron_schedule" table.

Any help would be appreciated!

1

If you are specifying the exact hours or minutes, magento calculates them with the timezone you defined inside Store -> Configuration -> General -> Locale Option -> Timezone (Default Config) to make entry in cron_schedule table.

Do not consider it to be your systems's current time.

0

is that cron running on the server?

try with * * * * * and check is that entry doing everry min

  • i have check with ' * * * * * ' and its working . but i want to execute cron every day @ 10.05 – Charvi Parikh May 17 at 11:17
  • are you using any module related to cron? have you run cron using n98? – Sunil Patel May 17 at 11:26
  • i have already run a command "php bin/magento cron:install" . i don't use any module related to cron – Charvi Parikh May 17 at 11:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.