1

If you open the front end with multiple tabs in the browser, the following error is output:.

Exception #0 (Exception): Warning: session_start(): Failed to read session data: user (path: /var/opt/remi/php71/lib/php/session) in /var/www/html/primary/vendor/magento/framework/Session/SessionManager.php on line 189

The www.conf file specifies the location of the session as follows:.

php_value[session.save_path]    = /var/opt/remi/php71/lib/php/session

The permissions for saving sessions are set as follows:.

total 0
drwxr-xr-x 5 www-data www-data 53 May 14 20:17 .
drwxr-xr-x 7 root     root     71 May 14 20:06 ..
drwxrwx--- 2 www-data www-data  6 May  1 18:33 opcache
drwxrwx--- 2 www-data www-data  6 May  1 18:33 session
drwxrwx--- 2 www-data www-data  6 May  1 18:33 wsdlcache

The configuration problem is complete, but an exception message is printed. Please tell me how to fix it.

Additional information. I also set up Redis. The settings are as follows:.

'session' => [
        'save' => 'redis',
        'redis' => [
            'host' => '127.0.0.1',
            'port' => '6381',
            'password' => '',
            'timeout' => '2.5',
            'persistent_identifier' => '',
            'database' => '2',
            'compression_threshold' => '2048',
            'compression_library' => 'gzip',
            'log_level' => '3',
            'max_concurrency' => '6',
            'break_after_frontend' => '5',
            'break_after_adminhtml' => '30',
            'first_lifetime' => '600',
            'bot_first_lifetime' => '60',
            'bot_lifetime' => '7200',
            'disable_locking' => '0',
            'min_lifetime' => '60',
            'max_lifetime' => '2592000'
        ]
    ],
  • did you try changing max_concurrency? Seems like that is your issue if you are opening multiple tabs – Anthony May 17 at 5:56
  • The initial value was set to "max _ concurrency = 6". What number should I set? – mr.hironobu May 17 at 6:18
  • i think the rough rule is 10% of your total php processes. I personally have mine set at 15 – Anthony May 17 at 6:21
  • Change settings and validate. If not, add a comment. At that time, I would be happy if you could answer my message. – mr.hironobu May 17 at 6:24
  • Sorry, i am not sure what you mean? – Anthony May 17 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.