1

I've developed a small custom module. It worked as expected but I can't save user permission: I can see the module in the admin panel and in the Role Resource Tab (System->Permissions->Roles), but when I tried to check the module and save the user role, it will say that it has been saved. But when I rechecked the user role, it is still unchecked.

adminhtml.xml:

 <menu>
    <Gestion translate="title" module="Gestion_Commande">
        <title>Navette</title>
        <sort_order>1000</sort_order>
        <children>
            <envoi>
                <title>Preparation Magasin Cursol</title>
                <sort_order>1</sort_order>
                <action>adminhtml/gestion/envoi</action>
            </envoi>
            <receptio>
                <title>Reception Begles</title>
                <sort_order>2</sort_order>
                <action>adminhtml/gestion/reception</action>
            </receptio>
            <crossdoc>
                <title>Crossdocking et Erreurs De Stock</title>
                <sort_order>3</sort_order>
                <action>adminhtml/gestion/crossdoc</action>
            </crossdoc>
        </children>
    </Gestion>
</menu>
<acl>
    <resources>
        <admin>
            <children>
                <Gestion translate="title" module="Gestion_Commande">
                    <title>Navette</title>
                    <sort_order>1000</sort_order>
                    <children>
                        <envoi>
                            <title>Preparation Magasin Cursol</title>
                            <sort_order>1</sort_order>
                        </envoi>
                        <receptio>
                            <title>Reception Begles</title>
                            <sort_order>2</sort_order>
                        </receptio>
                        <crossdoc>
                            <title>Crossdocking et Erreurs De Stock</title>
                            <sort_order>3</sort_order>
                        </crossdoc>
                    </children>
                </Gestion>
            </children>
        </admin>
    </resources>
</acl>

I've seen this post, but it doesn't seem to be the same problem

Can't Save Role Resource for Custom Module

any ideas?

EDIT

Now access are granted successfully, but when I rechecked the user role, it is still unchecked...

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.