0

If i run the cron command php bin/magento cron:run im receiving the below error.

  [Magento\Framework\Exception\LocalizedException]                         
  Invalid Document                                                         
  Element 'group', attribute 'name': The attribute 'name' is not allowed.  
  Line: 9

So i searched and found out that it is an issue with missing 'title' in some acl.xml file. I tried applying many fixes which i found online but still the issue persist.

Please help me sort this issue. Kind regards.

  • What mode is magento running on? – Dominic Xigen May 15 at 19:13
  • @DominicXigen Dev mode – Thowzif May 15 at 19:36
0

Try switching to default mode. Not a great solution but either custom extension or theme has invalid XML and it will take a long time to track down

0

The issue was caused by a third party extension like expected and i had to disable all third party extensions and enable them one by one and ran curn if its running with out the above error.

If you have this error do the below steps to find the extension causing the issue;

  1. Disable all third party extensions(Including the ones that came with the theme)
  2. Run the cron to see if its successful.
  3. If its ok then start enabling one extension and try to run cron again.
  4. You will eventually find the extension(s) making the issue.

Hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.