1

I had problem with Mageplaza German Lanuage Pack. I have recently installed Magento 2.3.1 with docker-compose on Ubuntu 18.04 LTS. I tried to install language pack using composer.

My Magento Installation folder is /var/www/mag enter image description here

First step is was to start docker-compose so I write in terminal:

dokcer-compose start

And got result:

enter image description here

Then I use command:

composer require mageplaza/magento-2-german-language-pack:dev-master

And got result: enter image description here

Then I use command:

bin/magento setup:static-content:deploy de_DE

And got result: enter image description here

So I decided to use command:

bin/magento setup:static-content:deploy -f de_DE

And got result: enter image description here

Then I use command:

bin/magento indexer:reindex
bin/magento cache:clean
bin/magento cache:flush

And got successful result no errors. Then I go to admin panel Stores/Configuration/Genral/Locale Options and select Germany enter image description here

Then flush cache and there is no Germany translations on frontend page. After installation via composer I've got new folder showing in PHPStorm: enter image description here

Did I do something wrong ?

Thanks in advance!

0

I am so late here. As far as I could see your screenshots, your steps are good and you have the extension folders there.

The reason why it's not yet visible on the frontend could be because you are using a custom theme. Did you try switching it to the default theme and check if it's working there?

You might need to do some customization to make it work for your theme? Maybe check the extension XML files how they are injecting it in the frontend.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.