1

Working on a client installation and trying to enter the access keys so I can connect to Magento Marketplace, I receive the following error upon saving the config:

Failed to connect to repo.magento.com port 443: Connection timed out

I confirmed that TLS is current - set to 1.2 on the Magento server (this was mentioned as a potential issue in another forum).

The current installation does NOT have an SSL certificate - could this be the problem?

If not, any other ideas?

**** EDIT ****

I found some articles talking about open SSL potentially being the issue. I hope some of this information helps to pinpoint the issue

I updated by open SSL, version is now: [root@s50-63-160-164 public_html]# openssl version OpenSSL 1.0.2r 26 Feb 2019

Verified that the same version is being used by PHP by running phpinfo() script: OpenSSL 1.0.2r 26 Feb 2019

Ran some additional tests per the following article: https://github.com/magento/magento2/issues/5239


$context = stream_context_create(); $contents = file_get_contents('https://repo.magento.com/packages.json', false, $context); // this fails


$context = stream_context_create(); $contents = file_get_contents('https://packagist.org/packages.json', false, $context); // this succeeds


[root@s50-63-160-164 public_html]# openssl s_client -connect repo.magento.com:443 -tls1_2

connect: Connection timed out

connect:errno=110


[root@s50-63-160-164 public_html]# openssl s_client -connect repo.magento.com:443 -tls1_1

connect: Connection timed out

connect:errno=110


0

Try

composer config -g -- disable-tls true

Also what about doing it I configuration?

https://magento.stackexchange.com/a/90984/70343

  • executed the composer command - all that changed is that it errored out much faster. The config is set up correctly (per the link you provided) – mwex501 May 15 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.