1

I have a strange issue with Magento 2.2.5 where two of my product attributes have its values showing in the Catalog Table, but when you click into the product itself to edit, the field for that attribute is empty.

Catalog table: enter image description here

Product edit form: enter image description here

I've tried a full reindex, and cleared the Magento cache as well, but none of that helps.

I've compared the two attribute configurations on a database level using:

SELECT * FROM `mydb`.`eav_attribute` WHERE `backend_type` = "varchar"

But the configurations are exactly the same as other attributes where it doesn't have such an issue.

I have also compared the actual value in database with other attributes that don't have this issue:

SELECT * FROM `catalog_product_entity_varchar`

Again, exactly the same.

Interesting note, when I duplicate the product, the two attributes are the only fields that do not get cloned over to the duplicate product. This means that the duplicate product has these two fields set to the field's default values, and even these default values don't appear in the Edit Product form! I have no idea what else I can try to fix this.

enter image description here

0

Checking the system log, I was hitting into this error:

[2019-05-27 04:12:12] main.WARNING: Attempt to load value of nonexistent EAV attribute '180' 
                        for entity type 'Magento\Catalog\Api\Data\ProductInterface'. [] []

Google-d this error and a whole bunch of unsolved problems showed up. It seems that many users are hitting into this error after migrating from Magento 1 to 2, but this was not my use case.

Then I stumbled upon this answer: Magento 2.2.4 adding new custom attribute error "Attempt to load value of nonexistent EAV attribute"

So apparently I had to run:

php bin/magento cache:flush

Clearing the cache from the admin UI was not enough. I'm not exactly sure what's the difference between running this command and clearing the cache from the UI, but that did the trick and solved my issue. I am now able to see the attributes in product edit screen, and able to change and save the attribute values without issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.