2

i have a issue when a try to access to my Magento Admin Panel and frontend default page.

the admin panel always shows epmty And the frontend default page show content but without CSS and JS:

how to fix it?

Admin panel: SS1 Default Frontend: SS2 Using: Windows - Xampp - Magento 2.3 - Chrome Browser

0

Deploy your static content and clear your cache

php bin/magento setup:static-content:deploy

php bin/magento cache:flush

If that doesn't resolve it, look at the permissions for the files.

  • I already did it but still the same result, how i can do that? (permissions for the files) – LuDev May 10 at 20:18
  • Do the files that are 404'ing in your console logs exist on your server in the path your browser is expecting? If yes, ls -la on the directory those files are contained in to see the permissions levels. You could also rm -rf var/view-preprocessed and rm -rf pub/static/frontend/ pub/static/adminhtml/ and then redeploy. – mlunt May 10 at 20:20
  • Not, the items that show error 404 are not in the specified folder i run the commands you provide and still same result. – LuDev May 10 at 20:39
0

Does your Magento 2.3 /pub/static/.htaccess file match the contents at Magento 2.3's GitHub Repo?

Are you in Developer or Production mode?

php bin/magento deploy:mode:show

Does this issue exist in developer mode?

php bin/magento deploy:mode:set developer

If this issue exists only in production mode, then try:

rm -rf pub/static/*
php bin/magento cache:flsuh
php bin/magento cache:clean
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy

Good Luck!

  • i will try... will send u the answer in couple minutes – LuDev May 11 at 23:19
  • php bin/magento deploy:mode:show -- > show "Default", php bin/magento deploy:mode:set developer -- > Broke the Magento i try to set restore using defualt ibut still magento is broke, i try the phps commands and still the same result. Thanks for u help and time. – LuDev May 12 at 0:04
0

Try this

Just Open the

MAGENTO_ROOT/app/etc/di.xml

and replace below code form line number 574

<item name="view_preprocessed" xsi:type="object">Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink</item>

TO

<item name="view_preprocessed" xsi:type="object">Magento\Framework\App\View\Asset\MaterializationStrategy\Copy</item>

and run below commands

rm -rf var/ generated/

run below commands

php bin/magento cache:clean & php bin/magento cache:flush
php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy
chmod -R 777 var/ generated/
  • i will try... will send u the answer in couple minutes – LuDev May 11 at 23:19
  • i try but still the same result. Thanks a lot for your time – LuDev May 11 at 23:57
  • in that case check permission of var and generated folders and also owner name of those directories. – ravichandra May 13 at 5:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.