1

Can Magento 1.9.4 run using PHP 7.3.5?

I have seen a number of Stack Exchange posts to the contrary and some supporting it.

I have PHP 7.3.5 installed on the server but how (if possible) do I tell Magento to use the latest version?

Kevin

1
  • depends on your web stack configuration, what you have inatalled?
    – MagenX
    May 11, 2019 at 11:32

2 Answers 2

2

Was there ever a solution to this? gets a lot of traffic would be good to know a lot of M1 users coming up to issues pertaining to this now.

Like me as well. Currently running 1.9.4.4 perfectly fine on 7.2, but server moving to 7.3 and want to make sure it will still be ok!

By the way, i had to post an answer because i do not have enough reputation to comment

1

I have checked and found something for you:

You can check the details report about PHP version support by Magento 1 here.

https://devdocs.magento.com/guides/m1x/ce19-ee114/ce1.9_release-notes.html#ce19-1941

So, As I have reviewed the doc it will support php7.2.

You can check the future information here.

https://devdocs.magento.com/guides/m1x/ce19-ee114/ce1.9_release-notes.html

6
  • Thanks for the info - any idea how to force Magento to use PHP 7.2, or is it a Server issue? May 10, 2019 at 12:00
  • your server have php 7.3? which server/hosting you are using?
    – Saphal Jha
    May 10, 2019 at 12:01
  • CentOS - yes, 7.3.2 May 13, 2019 at 8:05
  • Is your server is dadicated?
    – Saphal Jha
    May 13, 2019 at 8:21
  • Not Dedicated, VPS - with SSH access May 13, 2019 at 8:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.