4

I'm having issues on the cart page and checkout of my Magento 2.3.1 CE store.

Most of the site is working totally fine but on the cart and checkout pages the shipping estimate and payment methods sections refuse to load.

Looking in the browser's network queue I see some AJAX requests are failing with a 500 internal server error like the following:

// AJAX POST request to
// https://example.com/uk/rest/uk/V1/guest-carts/[cart_token]/estimate-shipping-methods

// Response:
PHP Fatal error:  Uncaught Error: Cannot instantiate interface Magento\Framework\MessageQueue\ConfigInterface in /var/www/vhosts/example.com/httpdocs/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php:50
Stack trace:
#0 /var/www/vhosts/example.com/httpdocs/vendor/magento/framework/ObjectManager/ObjectManager.php(70): Magento\Framework\ObjectManager\Factory\Dynamic\Developer->create('Magento\\Framewo...')
#1 /var/www/vhosts/example.com/httpdocs/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php(160): Magento\Framework\ObjectManager\ObjectManager->get('Magento\\Framewo...')
#2 /var/www/vhosts/example.com/httpdocs/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php(246): Magento\Framework\ObjectManager\Factory\AbstractFactory->resolveArgument(Array, 'Magento\\Framewo...', NULL, 'queueConfig', 'Magento\\Asynchr...')
#3 /var/www/vhosts/example.com/httpdocs/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php( in /var/www/vhosts/example.com/httpdocs/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php on line 50

I've not disabled any default modules or anything like that, and I've run the usual checklist of clearing caches, composer update, setup:upgrade, etc. etc.

Mostly everything else is working after a successful migration from Magento 1. Just this issue remains.

Any ideas?

2

The solution was to force a re-install of the 2.3.1 upgrade. Muhammad's answer was on the right track, but I had to take some extra steps because his instructions are only for people who had problems during the upgrade process - which I didn't. I discovered these problems a while after I had upgraded to 2.3.1.

Anyway, first of all I reinstalled the Magento Base module by editing vendor/composer/installed.json and renaming magento/magento2-base to __magento/magento2-base (basically making Composer think the module is not installed as per this comment) and running composer install.

Then I downloaded Magento's command line upgrade script and followed the instructions from that page very carefully.

It seems to have worked - I assume the problem was that one of Magento's base modules hadn't installed or updated correctly because I didn't follow Magento's recommended upgrade procedures as carefully as I should have. Forcing a reinstall of the base modules and re-running the upgrade correctly seems to reset everything to working.

If that hadn't worked my next alternative was probably going to be to delete everything inside the vendor directory, and run composer install again - essentially forcing all dependencies to reinstall from scratch.

1

One of the possible solution recommended to resolve these errors, perform the following tasks:

  1. Log in to your Magento server as, or switch to, the Magento file system owner.

If you don’t have access to the Magento server file system, connect to it using an FTP application.

  1. Remove the following files so you can upgrade again:

    <magento_root>/var/.maintenance.flag <magento_root>/var/.update_in_progress.flag <magento_root>/var/cache/* <magento_root>/var/page_cache/* <magento_root>/var/generation/*

  2. Run your upgrade again, making sure to complete all tasks discussed in Run System Upgrade.

Reference: https://devdocs.magento.com/guides/v2.3/comp-mgr/trouble/cman/upgrade_51431.html

  • I assume this refers to the upgrade from 2.3.0 to 2.3.1? I did the upgrade via the command line, not using the Magento upgrade page, if that makes a difference. Do you know if re-running the upgrade will cause any damage to my existing files or database content? – WackGet May 9 at 16:19
  • OK, this wasn't the exact solution because those instructions are only for people who had problems during the upgrade process - which I didn't. I discovered these problems a while after I had upgraded to 2.3.1. So I'll post my own answer but your answer was helpful and relevant too, so thank you! – WackGet May 10 at 2:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.