1

I want to fix a website that was done by another person but I do not want to break the live version of it. So I downloaded the whole website completely and the live database, installed everything on a local web-server and fixed "core_config_data" table (web/secure/base_url, web/unsecure/base_url) and "local.xml" file.

The main page is just wrong, it's all scuffed. I inspected the code and it seems to show some other template in general. Some menus are wrong and some elements do not even exist in it. But I copied the whole website, how is it possible that I receive incorrect output by pretty much copypasting the code?

I do not know how to debug this, Magento seems huge, I would love to hear suggestions and, possibly, steps for debug process. Thank you.

  • Can you please share the screenshot or any error so we can figure out the issue. – poojan sharma May 8 at 4:08
  • @poojansharma hey! It's not like there's an error. It's just that I cloned the website and what I see is different from what it is on the live platform online (from what it supposed to be). I tried to look for a solution but I do not even know where to start. – Telion May 8 at 4:31
  • other places to look when migrating would be .htaccess which may have special rules that are not running on your local version, also don't forget cookie domain in core_config_data. index.php for hardcoded domains is also another good one i've come across realistically you probably need to share what the differences are (wrong theme? blocks not showing? white page of death?) – bjornredemption May 8 at 4:38
  • @bjornredemption thanks. .htaccess looks very straightforward and clean. "cookie domain" from magento.stackexchange.com/questions/6426 I already checked. What do I see? Well, it's a different version of the website for sure. Some blocks use different content (like menus have old names and different order), some blocks do not exist (like carousel), some styles aren't loaded blocks are all across the screen, jQuery is not loaded for some reason, while some parts of the script require it and console is full of errors about this. Because content differ I think it's a different version – Telion May 8 at 5:41
  • 1
    The current theme is defined in the admin under System > Configuration > Design so will not be affected if you have brought across the correct DB. – bjornredemption May 9 at 2:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.