2

While I am try to load magento home after installation, page not loading properly. enter image description here

enter image description here

  • are you checking into window? – Sunil Patel May 7 at 6:09
  • @Sakthivel were you able to solve this? – fmsthird May 9 at 5:11
0

open cmd or terminal in root directory and run static content command

php bin/magento s:s:d -f

then clean your cache

php bin/magento c:c

hope that helps

  • I used to run this command in comment terminal, cd xampp/htdocs/e-commerce C : \xampp/htdocs/e-commerce >php bin/magento s:s:d -f It generate error "php is not recognized as an internal or external command". – Sakthivel May 7 at 6:19
  • ok run it there – Asad Ullah May 7 at 6:20
0

After installing Magento,

Deploy the theme by default on first time LUMA theme will be enabled

Try below commands to get it done

  1. php bin/magento setup:upgrade // this help to upgrade or the module which newly added or updated in some point.

  2. php bin/magento setup:static-content:deploy // for default or production mode, this will help to deploy the all themes which all are able in magento,

Assuming you executing all these commands just after magento install, because default magento mode is default, if you changed to developer mode by running( php bin/magento deploy:mode:set developer) then in above command need to added (-f)

so for developer mode run php bin/magento setup:static-content:deploy -f // for developer mode

  1. php bin/magento cache:clean

then go to store-front hope you will get your expected output.


Note : some time installing XAMPP or PHP first time, it not set environment variable for PHP

so running php command that time we are getting error : "php is not recognized as an internal or external command"

to solved this we need to set environment variable. I am assuming XAMPP is install in C: drive so php path is C:\xampp\php in your case might be something else but just to go to php folder in xampp and copy the path and added into your PATH environment variable or follow these link.

Then close your command prompt and restart again (Important if you do not restart your command prompt then changes will not be reflected so best to restart XAMPP and command prompt).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.