1

Every time I update a product stock in magento it updates perfectly in the backend but only when I manually run a reindex via SSH does it update on the front end.

Very annoying when I am sometimes updating stock several times a day with deliveries.

So for example a product has 0 in stock, if i change to qty 5 the back end shows in stock qty 5 but front end still shows out of stock. After reindex it updates on the front end.

Any idea what is wrong?

  • How do you set the reindex to happen by schedule or on save – Raj Mohan R May 2 at 17:57
  • Have you set proper cron jobs? – Rizwan Khan May 3 at 5:06
2

You can change indexing settings to, update on save,

here is the difference:

Update on Save :The index is set to update whenever a change is saved.

Update on Schedule :The index is set to update on schedule according to a cron job.

0

Check your Cron, and Cron logs.

You can also run

php bin/magento cron:install

Cron jobs are responsible for reindex

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.