I couldn't find anything about this on Google.

I have to work on search functionality in a Magento site I didn't install.

For some reason the Catalog -> Search Terms menu is missing:


Any cue/help?

enter image description here

EDIT: I found out that I can reach the page from the dashboard. I have to click on any of the Top 5 Search Terms and then click on <- Back

Anyway the issue is very strange and I didn't find a solution.

  • I think the admin user from which you are logged in doesnt have sufficient ACL permissions. Try making a new admin user with all permissions and then login from that user. You can use following link to create a new admin user from database atwix.com/magento/reset-admin-password-mysql
    – surbhi agr
    May 2, 2019 at 9:32
  • @surbhiagr, thanks for your help. The user I'm using is an Administrator with all permissions. Anyway I tried what you wrote but unfortunately the problem still remains: no Catalog -> Search Terms menu
    – stravanato
    May 2, 2019 at 10:30

1 Answer 1


That menu point is provided by CatalogSearch core module (in app/code/core/Mage/CatalogSearch/etc/adminhtml.xml file)

Assuming you are logged in as an administrator, so you can view all menu points, the first thing I would check would be System > Configuration > Advanced > Advanced. You can see there, searching by "Mage_CatalogSearch", if module's output for that module is enabled (it seems it has been disabled)

Other things that could explain your problem: check your project for any 3rd party module rewriting CatalogSearch functionality. Maybe some module is hiding that menu point

Last thing (not probable, as I don't think you can disable that module without breaking something), check CatalogSearch core module is enabled by browsing app/etc/modules xml files

  • thanks a lot for you answer. I checked what you wrote: Mage_CatalogSearch module's output is enabled, CatalogSearch core module is enabled in app/etc/modules. Also I looked for anything like <menu><catalog><children><search>... in 3rd party modules but I didn't find anything.
    – stravanato
    May 2, 2019 at 12:33
  • Any info in Magento logs at var/log folder? May 3, 2019 at 7:18
  • Lots of these, but don't think they're meaningful: 2019-05-03T07:20:27+00:00 ERR (3): Notice: Undefined index: show_notice in /app/design/frontend/default/sm_sport/template/page/sm/yt_config_inc.php on line 114 2019-05-03T07:20:28+00:00 ERR (3): Notice: Undefined index: white_border_image in /app/design/frontend/default/sm_sport/template/hideprice/list.phtml on line 52
    – stravanato
    May 3, 2019 at 7:23
  • Also I tried this: I made a new role specifying every single permission including Search Terms and I gave the role to my admin but nothing, even worse because other menu items missing.
    – stravanato
    May 3, 2019 at 7:26
  • Another try... check app/code/local/Mage folder... maybe a CatalogSearch folder there? If not, and considering the functionality is working, you can always create a local module to recover the menu point, copying the relevant code in app/code/core/Mage/CatalogSearch/etc/adminhtml.xml May 3, 2019 at 7:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.