0

I have followed all the instructions:
Advanced Reporting
Also Magento Analytics user integration Status is “Active.” But still facing the same error.
How can i enable Advance Reporting m using magento2.3 EC. Is this Reporting is paid or free.

enter image description here

0

Please check video and refer magento 2 devdocs, this will help you:

https://www.youtube.com/watch?v=2N8jSiNk1io

https://devdocs.magento.com/guides/v2.3/advanced-reporting/overview.html

https://community.magento.com/t5/Magento-2-x-Technical-Issues/Advanced-Reporting-doesn-t-work-and-there-is-an-error-404/td-p/126904

  • I have done already . But still shows pending and does't show advance reporting – Hafiz Arslan May 7 at 6:07
  • Is your website is on https? – Saphal Jha May 7 at 6:08
  • yes, rcg.com.pk – Hafiz Arslan May 7 at 6:10
  • flush all the cache and wait for next scheduled update (may be in 24 hours), it should work. – Saphal Jha May 7 at 6:14
  • I have done. And wait last two days but no success. – Hafiz Arslan May 7 at 6:16
0

Admin and CMD line changes

1) run below query
delete from flag where flag_code='analytics_previous_base_url'; 
2) Go to 
 Store >> Configuration  >> General >> Advanced Reporting 
https://www.screencast.com/t/YEQbaKv9Gh first disabled and do enabled again.

3) 
Go to
Store >> Configuration >> Main Website >> General >> Web >> Base URL & Secure Base URL  (make sure admin url and default website url same)
Store >> Configuration >> Default Config >> General >> Web >> Base URL & Secure Base URL(make sure admin url and default website url same)

4) go to admin System >> Integration 
https://www.screencast.com/t/L8GrKS5L 

5) you need to click reauthorization on Magento Analytics user  
do reauthorization again for analytics use 

6) then do a cache flush 
php bin/magento c:f config 

7) n98-magerun2 sys:cron:run analytics_subscribe 
run above command to create account https://dashboard.rjmetrics.com/ 
check system.log file
for me giving below error
report.WARNING: Subscription for MBI service has been failed. An error occurred during token exchange: {"message":"Handshake request failed

So i find ip of MBI and added into whitelist IP

 how to find IP :
go to /log/access.log and search integration/tokensDialog  from that row you will find IP address

8) n98-magerun2 sys:cron:run analytics_update 

9) n98-magerun2 sys:cron:run analytics_collect_data 
  • me giving below error report.WARNING: Subscription for MBI service has been failed. An error occurred during token exchange: {"message":"Handshake request failed when u receive this error your site was going to down or not ? – Hafiz Arslan May 7 at 7:43
  • are you using something like ip restication ? or htpwd? – Sunil Patel May 7 at 14:25
  • not now ,, because my site is live i didn't want risk to do something which cause site goes down , that's why i asked – Hafiz Arslan May 8 at 5:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.