1

Good Morning

I have been developing the following project that has the purpose of automating the construction of Magento2, in order to facilitate the evangelization of the platform

https://github.com/mozgbrasil/deploy-magento2#install

The installation of Magento works as expected by displaying all images from the "sample data"

But at the time of re-deploying the magento, it is that problems occur

https://github.com/mozgbrasil/deploy-magento2#deploy--re-deploy

Images of some categories are not displayed and the file "/pub/media/styles.css" that should be generated on the home page is not displayed

-

I even did the following test

delete the magento folder

I used the composer to download and install the magento

Access and test where it worked as expected

I renamed the magento folder

Then

I used the composer to download and redeploy the magento due to the presence of the database

This is where the problem happens

But if I rename this last deployment folder and use the previous one it works

-

To whom I can contribute with the project, I thank you

-

I have a deployment at AWS EBS in

http://304674501456-test-webapp014.us-west-2.elasticbeanstalk.com/

The magento is in

http://304674501456-test-webapp014.us-west-2.elasticbeanstalk.com/magento/

and the backend in

http://304674501456-test-webapp014.us-west-2.elasticbeanstalk.com/magento/admin/

You can access how

admin / 123456a

-

See that you already have this link and the cache is disabled

-

0

Try adding this link in Styles->Configurations->your_theme->HTML Head->Miscellaneous scripts

<link rel="stylesheet" type="text/css" media="all" href="{{MEDIA_URL}}styles.css" />

Clean your cache and check it.

If not file appears try manually copying the styles.css into pub/media

  • 1
    I have reformulated my question and put the access data to the backend where we see that the link exists and the cache is disabled As my project is public, I think it should be easier to implement a possible correction, if you can help now thank you – Marcio dos Santos Amorim mozgb Apr 29 '19 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.