2

I am faced issue when I upgrade Magento 2.1.1 to Magento 2.1.17

I changed some values in composer.json

"magento/product-community-edition": "2.1.1", =>"magento/product-community-edition": "2.1.17",

"version": "2.1.1", => "version": "2.1.17",

I keep getting this error message

Your requirements could not be resolved to an install able set of packages.



Problem 1
- Can only install one of: magento/framework[100.1.17, 100.1.1].
- Can only install one of: magento/framework[100.1.17, 100.1.1].
- Can only install one of: magento/framework[100.1.1, 100.1.17].
- magento/product-community-edition 2.1.17 requires magento/framework 100.1.17 -> satisfiable by magento/framework[100.1.17].
- Installation request for magento/product-community-edition 2.1.17 -> satisfiable by magento/product-community-edition[2.1.17].
- Installation request for magento/framework == 100.1.1.0 -> satisfiable by magento/framework[100.1.1].

I tried to fix this problem by adding this line

"magento/framework": "100.1.17|100.1.1.*", in "require"

but no luck

Any help would be appreciate.

  • If answer helpful please accept and upvote – Sanjay Gohil Apr 24 at 11:03
1

Don't make any change in composer.json Leave it as it is

Run below code from your project root

1) composer require magento/product-community-edition 2.1.17 --no-update
2) composer update

Now run below command

1) php bin/magento setup:upgrade
2) php bin/magento setup:static-content:deploy -f
3) php bin/magento indexer:reindex
4) php bin/magento cache:flush

Now login back to your admin and check your Magento version.

  • You're welcome, Help each other..! Happy coding..! – Sanjay Gohil Apr 25 at 4:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.