2

I m working on custom extension and I stumble across this

The contents from the "/var/www/html/pub/static/frontend/Magento/blank/en_U
S/ImaginationMedia_SocialOrder/css/orders/list.css" file can't be read. War
ning!file_get_contents(/var/www/html/pub/static/frontend/Magento/blank/en_U S/ImaginationMedia_SocialOrder/css/orders/list.css): failed to open stream: No such file or directory

More information

> Deploy using quick strategy frontend/Magento/blank/en_US           
> 0/2335              >-------------------frontend/Magento/blank/en_US  
> 890/2335            ==========>---------frontend/Magento/blank/en_US  
> 1517/2335           ==================>--------- 64% %   2 secs
> #0 /var/www/html/vendor/magento/framework/App/View/Asset/Publisher.php(74):
> Magento\Framework\View\Asset\File->getSourceFile()
> #1 /var/www/html/vendor/magento/framework/App/View/Asset/Publisher.php(62):
> Magento\Framework\App\View\Asset\Publisher->publishAsset(Object(Magento\Framework\View\Asset\File))
> #2 /var/www/html/vendor/magento/module-deploy/Service/DeployStaticFile.php(89):
> Magento\Framework\App\View\Asset\Publisher->publish(Object(Magento\Framework\View\Asset\File))
> #3 /var/www/html/vendor/magento/module-deploy/Service/DeployPackage.php(184):
> Magento\Deploy\Service\DeployStaticFile->deployFile('css/orders/list...',
> Array)
> #4 /var/www/html/vendor/magento/module-deploy/Service/DeployPackage.php(131):
> Magento\Deploy\Service\DeployPackage->processFile(Object(Magento\Deploy\Package\PackageFile),
> Object(Magento\Deploy\Package\Package))
> #5 /var/www/html/vendor/magento/module-deploy/Service/DeployPackage.php(102):
> Magento\Deploy\Service\DeployPackage->deployEmulated(Object(Magento\Deploy\Package\Package),
> Array, false)
> #6 [internal function]: Magento\Deploy\Service\DeployPackage->Magento\Deploy\Service\{closure}()
> #7 /var/www/html/vendor/magento/framework/App/State.php(187): call_user_func_array(Object(Closure), Array)
> #8 /var/www/html/vendor/magento/module-deploy/Service/DeployPackage.php(103):
> Magento\Framework\App\State->emulateAreaCode('frontend',
> Object(Closure))
> #9 /var/www/html/vendor/magento/module-deploy/Process/Queue.php(310): Magento\Deploy\Service\DeployPackage->deploy(Object(Magento\Deploy\Package\Package),
> Array)
> #10 /var/www/html/vendor/magento/module-deploy/Process/Queue.php(229): Magento\Deploy\Process\Queue->execute(Object(Magento\Deploy\Package\Package))
> #11 /var/www/html/vendor/magento/module-deploy/Process/Queue.php(208): Magento\Deploy\Process\Queue->executePackage(Object(Magento\Deploy\Package\Package),
> 'frontend/Magent...', Array, false)
> #12 /var/www/html/vendor/magento/module-deploy/Process/Queue.php(162): Magento\Deploy\Process\Queue->assertAndExecute('frontend/Magent...',
> Array, Array)
> #13 /var/www/html/vendor/magento/module-deploy/Strategy/QuickDeploy.php(76):
> Magento\Deploy\Process\Queue->process()
> #14 /var/www/html/vendor/magento/module-deploy/Service/DeployStaticContent.php(112):
> Magento\Deploy\Strategy\QuickDeploy->deploy(Array)
> #15 /var/www/html/setup/src/Magento/Setup/Console/Command/DeployStaticContentCommand.php(140):
> Magento\Deploy\Service\DeployStaticContent->deploy(Array)
> #16 /var/www/html/vendor/symfony/console/Command/Command.php(255): Magento\Setup\Console\Command\DeployStaticContentCommand->execute(Object(Symfony\Component\Console\Input\ArgvInput),
> Object(Symfony\Component\Console\Output\ConsoleOutput))
> #17 /var/www/html/vendor/symfony/console/Application.php(893): Symfony\Component\Console\Command\Command->run(Object(Symfony\Component\Console\Input\ArgvInput),
> Object(Symfony\Component\Console\Output\ConsoleOutput))
> #18 /var/www/html/vendor/symfony/console/Application.php(262): Symfony\Component\Console\Application->doRunCommand(Object(Magento\Setup\Console\Command\DeployStaticContentCommand),
> Object(Symfony\Component\Console\Input\ArgvInput),
> Object(Symfony\Component\Console\Output\ConsoleOutput))
> #19 /var/www/html/vendor/magento/framework/Console/Cli.php(102): Symfony\Component\Console\Application->doRun(Object(Symfony\Component\Console\Input\ArgvInput),
> Object(Symfony\Component\Console\Output\ConsoleOutput))
> #20 /var/www/html/vendor/symfony/console/Application.php(145): Magento\Framework\Console\Cli->doRun(Object(Symfony\Component\Console\Input\ArgvInput),
> Object(Symfony\Component\Console\Output\ConsoleOutput))
> #21 /var/www/html/bin/magento(23): Symfony\Component\Console\Application->run()

I tried to create the directory needed for both luma & blank a new "list.css" and chmod for permission, then deploy again .It works but ended up with a magento2 with no CSS(Just work no picture no css) at all,am I missing anything here?

  • 1
    can you add the layout file wherein you added your custom css, I mean the code – fmsthird Apr 24 at 3:15
  • if you have a custom module, it is better to add your custom css from there to avoid such errors – fmsthird Apr 24 at 3:17
  • I m pretty new to magento2.could you further elaborate on what I should do? or point me a reference on what I should do to make it work?on layout file what should i include?and where should i put the xml file on? – Ed Tan Apr 24 at 3:19
  • 1
    you can check this on how to properly add your custom css devdocs.magento.com/guides/v2.3/frontend-dev-guide/layouts/… – fmsthird Apr 24 at 3:21
  • Thanks again for guiding the walkthrough – Ed Tan Apr 24 at 3:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.