1

Basically the loader inside this page does not disappear after the page is loaded, some have fixed this by fixing console errors (I have none) other by fixing their onepage.phtml (Looks good to me) with nothing else to go off i'm hoping to find some kind of solution here.

What the loader looks like before its fully loaded, looks normal. What the loader looks like before What the loader looks life after, now missing its data-mage-init enter image description here

Inside app\design\frontend\pcnametag\pcnametag_canada\Magento_Checkout\templates\onepage.phtml

<script>
    require(['jquery'],function($){
        $(document).ready(function() {
            ga('send','event','Checkout','Step 1 - Checkout Method', {nonInteraction: true});
        });
    });
</script>
<div id="checkout" data-bind="scope:'checkout'" class="checkout-container">
    <div id="checkout-loader" data-role="checkout-loader" class="loading-mask" data-mage-init='{"checkoutLoader": {}}'>
        <div class="loader">
            <img src="<?= /* @escapeNotVerified */ $block->getViewFileUrl('images/loader-1.gif') ?>"
                 alt="<?= /* @escapeNotVerified */ __('Loading...') ?>"
                 style="position: absolute;">
        </div>
    </div>
    <!-- ko template: getTemplate() --><!-- /ko -->
    <script type="text/x-magento-init">
        {
            "#checkout": {
                "Magento_Ui/js/core/app": <?= /* @escapeNotVerified */ $block->getJsLayout() ?>
            }
        }
    </script>
    <script>
        window.checkoutConfig = <?= /* @escapeNotVerified */ $block->getSerializedCheckoutConfig() ?>;
        // Create aliases for customer.js model from customer module
        window.isCustomerLoggedIn = window.checkoutConfig.isCustomerLoggedIn;
        window.customerData = window.checkoutConfig.customerData;
    </script>
    <script>
        require([
            'mage/url',
            'Magento_Ui/js/block-loader'
        ], function(url, blockLoader) {
            blockLoader("<?= /* @escapeNotVerified */ $block->getViewFileUrl('images/loader-1.gif') ?>");
            return url.setBaseUrl('<?= /* @escapeNotVerified */ $block->getBaseUrl() ?>');
        })
    </script>
</div>

No errors in the console, everything in network tab coming back as 200 enter image description here

  • 1
    check in error report sometimes it is not displayed on the frontend – fmsthird Apr 23 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.