0

I was using UPS in my Magento 2 store, from today I found that the shipping methods are not fetched and they are displayed with the message

Unfortunately we cannot provide a shipping quote at this time

I tried to enable debug log for UPS and no log was found. The same issue does occur in the dev site too from today. Please find the configurations

enter image description here enter image description here enter image description here

So I tried UPS in another live store where UPS type was UPS XML, it was displaying shipping rates fine. I switched type to UPS and the shipping rates weren't fetched. I checked it in fresh Magento too. Does anyone have an idea about this? Else anyone facing the same problem? Whether might it be an issue with UPS API service?

1

Update Gateway Url of UPS from http to https From “http://www.ups.com/using/services/rave/qcostcgi.cgi” to “https://www.ups.com/using/services/rave/qcostcgi.cgi”.

Refer this link What is the current UPS shipping gateway? (outage 2019-01-06)

  • Thank you. That is working fine. But I am don't know how the gateway was working fine for almost 2 months after the change – Raj Mohan R Apr 23 at 8:56
  • Actually, i ran into the problem in January and again early last week. I had changed my config but it turned out that the old value got pulled in from the cache somehow. So, I assume UPS reverted their https requirement at some point, then re-applied it last week, else my site would have been broken again before last week. – M Conrad Apr 23 at 22:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.