2

As per this bug report, I'm having an issue where I'm unable to save any changes to product attributes in the Magento 2 admin area.

When I try to change settings of any attribute and hit save, a POST request is made to (e.g.) https://example.com/admin/catalog/product_attribute/validate/attribute_id/200/?isAjax=true but it receives no response.

The page then reloads to a more basic URL of https://example.com/admin/catalog which results in a 404 error, and the changes are not saved.

There are no errors visible.

Please note I have tried clearing (and disabling) all caches, indexes, deployed static content, checked file/folder permissions, etc. and this is still happening.

Any ideas, please?

1

Be sure there are no duplicate attributes, it can happen and cause this issue.

If there's a default attribute selected, try selecting a different attribute as default, and dragging it to the bottom of the sorting list and save - this actually worked for a similar issue I had. But if it doesn't save the new default or order, keep reading.

Check your phpinfo() for max_input_vars, you might need a higher number, if you have a lot of attributes. But this should be in your error logs, but can be an issue.

Try turning off your cache via CLI bin/magento cache:disable and see if the attributes will save with the cache off.

If still having issues, set your store to developer mode in CLI bin/magento deploy:mode:set developer then, run composer update and bin/magento setup:upgrade. That should update all software and modules, if they're causing the issue.

Last attempt, try running in CLI

composer update
bin/magento setup:upgrade
bin/magento deploy:mode:set production

It's less verbose, and seems to work better on some settings when other methods don't work. If you get an error about a directory not being empty when you run bin/magento deploy:mode:set production just try it 3 or 4 more times and it 'should' eventually run.

I hope that helps, I had a similar issue, and it deleted every swatch from my colors, and all the sizes from the admin, but not in the DB.

  • Thanks, increasing max_input_vars helped. – Viperet Aug 22 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.