2

i am setup authorised.net in localhost

when i pay using this payment method it gives error Root element is missing.

http://prntscr.com/ncmprk

anyone have a solution for this type of error

admin configuration
http://prntscr.com/ncmquc
http://prntscr.com/ncmqzz

  • Are you sure the credentials you are using are setup for dev in authorize.net? – Arshad Hussain Apr 16 at 12:58
  • yes the credential are correct – Jigs Parmar Apr 17 at 4:04
  • Have you got any success? – Yogita May 15 at 18:22
  • is there any solution because i have same problem? – Akshay Thakkar Jul 17 at 6:28
  • site url must be in https – Jigs Parmar Jul 17 at 6:40
0

Go to checkout and see where your credit card details are sending to. Enter the credit card details and open the Network tab in Inspect element tool then place an order. You can see the requests.

Live Transaction URL - https://api.authorize.net/xml/v1/request.api

If you send Test credit card details to above URL, you will get "Root element is missing" error.

{"messages":{"resultCode":"Error","message":[{"code":"E00003","text":"Root element is missing."}]}}

0

Check all settings in authorize and try checking in production mode

adding http://prntscr.com/oskwta http://prntscr.com/oskttd

Default Receipt URL = https://your_domen Default Relay Response URL = https://your_domen/authorizenet/directpost_payment/response

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.