5

Getting error like below :

1 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): Only default scope allowed

Exception #0 (Magento\Framework\Exception\LocalizedException): Only default scope allowed
#0 /home/krishsdn/public_html/rabitgo/app/code/Codazon/ThemeOptions/Framework/App/Config/ScopePool.php(86): Codazon\ThemeOptions\Model\Config\Reader\DefaultReader->read(0)
#1 /home/krishsdn/public_html/rabitgo/app/code/Codazon/ThemeOptions/Model/Config/Loader.php(94): Codazon\ThemeOptions\Framework\App\Config\ScopePool->getScope('default', 0)
#2 /home/krishsdn/public_html/rabitgo/app/code/Codazon/ThemeOptions/Model/Config.php(450): Codazon\ThemeOptions\Model\Config\Loader->getConfigByPathForLoadForm('general_section', 'default', 0, '6', false)
#3 /home/krishsdn/public_html/rabitgo/app/code/Codazon/ThemeOptions/Model/Config.php(331): Codazon\ThemeOptions\Model\Config->_getConfigForLoadForm(false)
#4 /home/krishsdn/public_html/rabitgo/app/code/Codazon/ThemeOptions/Block/Adminhtml/Config/Form.php(158): Codazon\ThemeOptions\Model\Config->load()
#5 /home/krishsdn/public_html/rabitgo/app/code/Codazon/ThemeOptions/Block/Adminhtml/Config/Form.php(171): Codazon\ThemeOptions\Block\Adminhtml\Config\Form->_initObjects()
#6 /home/krishsdn/public_html/rabitgo/app/code/Codazon/ThemeOptions/Block/Adminhtml/Config/Form.php(475): Codazon\ThemeOptions\Block\Adminhtml\Config\Form->initForm()
#7 /home/krishsdn/public_html/rabitgo/vendor/magento/framework/View/Element/AbstractBlock.php(666): Codazon\ThemeOptions\Block\Adminhtml\Config\Form->_beforeToHtml()
#8 /home/krishsdn/public_html/rabitgo/vendor/magento/framework/View/Layout.php(558): Magento\Framework\View\Element\AbstractBlock->toHtml()
#9 /home/krishsdn/public_html/rabitgo/vendor/magento/framework/View/Layout.php(534): Magento\Framework\View\Layout->_renderBlock('adminhtml\\confi...')
#10 /home/krishsdn/public_html/rabitgo/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('adminhtml\\confi...')
#11 /home/krishsdn/public_html/rabitgo/vendor/magento/framework/View/Layout.php(489): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('adminhtml\\confi...')
#12 /home/krishsdn/public_html/rabitgo/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('adminhtml\\confi...', true)
#13 /home/krishsdn/public_html/rabitgo/vendor/magento/framework/View/Element/AbstractBlock.php(507): Magento\Framework\View\Layout\Interceptor->renderElement('adminhtml\\confi...', true)
#14 /home/krishsdn/public_html/rabitgo/app/code/Codazon/ThemeOptions/view/adminhtml/templates/system/config/edit.phtml(22): Magento\Framework\View\Element\AbstractBlock->getChildHtml('form')

If anyone aware about this error please suggest me to solve this.

Thank you in advance.

  • Is your admin user has access to all store resources? – fmsthird Apr 16 at 0:56
  • Yes admin has full access of panel @magefms – Praveen Chelumalla Apr 16 at 4:08
  • are you using default theme? – fmsthird Apr 16 at 4:16
  • 1
    what's in app/code/Codazon/ThemeOptions/Framework/App/Config/ScopePool.php around line 86 ? – Marius Apr 16 at 6:10
0

I had the same, or at least very similar issue, with a codazon theme. After some digging, I noticed my store id was incorrect in my URL string. It might have been a cache issue. When you look at your admin url when going to the theme options, check out this part... "general_section/theme_id/x/store/x/". In my case, the "theme_id" was showing "0" when it should have been "1".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.