1

I have installed magento2.3.1 in example.com/test/ folder through commandline.Installed successfully. but when opening url in browser http://example.com/test/

it shows error enter image description here

in backend it shows error

enter image description here

  • Check your .htaccess file and also check the permissions for generation/ var/ and pub are correctly set. – Dava Gordon Apr 15 '19 at 10:42
0

Have you got any more information?

Have you ran the following, after upgrading?

php bin/magento setup:upgrade && php bin/magento deploy:mode:set production

If you still get the error pages after that, what happens if you put:

die(__FILE__);

At the top of index.php or pub/index.php (depending on your setup)

  • var/www/html/example.com/public_html/test/index.php this is the output – Asha Apr 15 '19 at 11:06
  • Nice one, so your requests are making it through, and php-fpm is working. If you take out the die and run something like: curl -kI http://example.com/test/ what is the output? – Adam Apr 15 '19 at 12:09
0

Enable error reporting in magento and check exact error

In app/bootstrap.php

  error_reporting(E_ALL);
  ini_set('display_errors', 1);

uncomment ini_set ( remove # ) #ini_set('display_errors', 1); to ini_set('display_errors', 1)

Or add this to index.php file.

error_reporting(E_ALL);
ini_set('display_errors', 1);

And also enable developer mode. First check current mode. run this cmd

   php bin/magento deploy:mode:show

it will so the current mode

if current mode is not developer than change mode to developer by this command

 php bin/magento deploy:mode:set developer

change permissions var/ pub/ generated/ forlder

 sudo chmod -R 777 var/ pub/ genereted/
  • i have done all these.but its not working. In debug.log file it shows Execution time: 127.85466098785 [] [] [2019-04-15 11:20:00] main.DEBUG: cache_invalidate: {"method":"GET","url":"example.com/test/","invalidateInfo":{"identifier":"interception"}} [] [2019-04-15 11:20:35] main.DEBUG: cache_invalidate: {"method":"GET","url":"example.com/test/","invalidateInfo":{"identifier":"SYSTEM_CONFIG"}} [] – Asha Apr 15 '19 at 11:26
  • Hello then disable cache and flush cache php bin/magento cache:flush , php bin/magento cache:disable I hope this will help – Surendra Kumar Ahir Apr 15 '19 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.