0

My custom module stopped loading ui_component based admin form of Magento 2.3.1, because of <htmlContent name="gallery"> , however it was working fine in Magento 2.3.0. No logs or reports found to follow the problem, only blank page.

Here is the code, which i remove and form load,

     <htmlContent name="gallery" sortOrder="22">
    <argument name="data" xsi:type="array">
        <item name="wrapper" xsi:type="array">
            <item name="label" xsi:type="string" translate="true">Images</item>
            <item name="collapsible" xsi:type="boolean">true</item>
            <item name="opened" xsi:type="boolean">false</item>
        </item>
    </argument>
    <settings>
        <wrapper>
            <canShow>true</canShow>
            <componentType>fieldset</componentType>
        </wrapper>
    </settings>
    <block name="gallery" class="Magento\Catalog\Block\Adminhtml\Product\Helper\Form\Gallery">
        <block class="ABC\Categorybanner\Block\Adminhtml\Categorybanner\Edit\Tab\Images" as="content">
            <arguments>
                <argument name="config" xsi:type="array">
                    <item name="parentComponent" xsi:type="string">categorybanner_index_form.categorybanner_index_form.block_gallery.block_gallery</item>
                </argument>
            </arguments>

        </block>
    </block>
</htmlContent>
0

Updated in magento version 2.3.1 From Magento 2.3.0

Newly added code in Maegnto 2.3.1 :

"isResizeEnabled": <?= /* @noEscape */ $block->getImageUploadConfigData()->getIsResizeEnabled() ?>

File :

vendor/magento/module-backend/view/adminhtml/templates/media/uploader.phtml

That object was not there earlier versions. $block->getImageUploadConfigData()

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.