2

I have installed Magento 2.3 using composer, now in admin, I cannot see Magento version it show as below :

Magento ver. No version set (parsed as 1.0.0)

EVeI i tried running below command from putty same issue there also

php bin/magento --version

Magento CLI No version set (parsed as 1.0.0)

1
  • Can i just ask what version of composer you are using Apr 15, 2019 at 10:13

1 Answer 1

1

Mine had the same issue. I downloaded the 2.3-develop from https://github.com/magento/magento2/tree/2.3-develop and looking at the composer.json file there is now version set in the source code. I opened my composer.json in the main install directory and added the line "version": "2.3-dev", between "type" and "license" lines as that is basically what my 2.2-dev code had.

1
  • This is still a problem in 2.4-develop. Is there a reason for this or are they just not bothering to fix it? I tried putting in "2.4-develop" but it gave me an error that it was an invalid version string. I then put in "2.4-dev" and it worked.
    – Mageician
    Jun 23, 2020 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.